fix madwifi hal target for mips*
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Aug 2008 09:59:00 +0000 (09:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Aug 2008 09:59:00 +0000 (09:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12435 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Makefile

index 699a4afd0a39547fd1f4ad733e00f34c798d4a60..adfd418b20b606fcbcfc74135acf204ef2ed51a0 100644 (file)
@@ -54,11 +54,20 @@ ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
   BUS:=
 endif
 
-ifeq ($(ARCH),mips)
-  HAL_TARGET:=mips-be-elf
-endif
-ifeq ($(ARCH),mipsel)
-  HAL_TARGET:=mips-le-elf
+ifneq ($(CONFIG_CPU_MIPS32_R2),)
+  ifeq ($(ARCH),mips)
+    HAL_TARGET:=mips32r2-be-elf
+  endif
+  ifeq ($(ARCH),mipsel)
+    HAL_TARGET:=mips32r2-le-elf
+  endif
+else
+  ifeq ($(ARCH),mips)
+    HAL_TARGET:=mips32-be-elf
+  endif
+  ifeq ($(ARCH),mipsel)
+    HAL_TARGET:=mips32-le-elf
+  endif
 endif
 ifeq ($(ARCH),i386)
   HAL_TARGET:=i386-elf