[backfire] backport r27635
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 12:00:33 +0000 (12:00 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 12:00:33 +0000 (12:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27636 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mountd/Makefile
package/mountd/patches/020-handle_timeout.patch [new file with mode: 0644]

index c5913763729cea3bb088f6b0aa145b3ace9be68d..b41318a7e80be68410c8958a7d326910692b5c08 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 # All rights reserved.
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mountd
 PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
diff --git a/package/mountd/patches/020-handle_timeout.patch b/package/mountd/patches/020-handle_timeout.patch
new file mode 100644 (file)
index 0000000..badf40f
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/lib/autofs.c
++++ b/lib/autofs.c
+@@ -140,6 +140,7 @@ static int fullread(void *ptr, size_t le
+ static int autofs_in(union autofs_v5_packet_union *pkt)
+ {
++      int res;
+       struct pollfd fds[1];
+       fds[0].fd = fdout;
+@@ -147,15 +148,19 @@ static int autofs_in(union autofs_v5_pac
+       while(1)
+       {
+-              if(poll(fds, 2, 1000) == -1)
++              res = poll(fds, 1, -1);
++
++              if (res == -1)
+               {
+                       if (errno == EINTR)
+                               continue;
+                       log_printf("failed while trying to read packet from kernel\n");
+                       return -1;
+               }
+-              if(fds[0].revents & POLLIN)
++              else if ((res > 0) && (fds[0].revents & POLLIN))
++              {
+                       return fullread(pkt, sizeof(*pkt));
++              }
+       }
+ }