build eeprom_93cx6 as a module, add a KernelPackage for it and for crc-itu-t
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Aug 2007 22:19:26 +0000 (22:19 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Aug 2007 22:19:26 +0000 (22:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8559 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk
target/linux/generic-2.6/config-2.6.22

index 68955874037ab2cc03ab82b01b4f1e7d1f3c9222..0e04ae97a7b3b829b4454db947ca31b29b9ac3f2 100644 (file)
@@ -8,6 +8,18 @@
 
 EMENU:=Other modules
 
+define KernelPackage/crc-itu-t
+  SUBMENU:=$(EMENU)
+  TITLE:=CRC ITU-T V.41 support
+  DESCRIPTION:=Kernel module for CRC ITU-T V.41 support
+  KCONFIG:=CONFIG_CRC_ITU_T
+  FILES:=$(LINUX_DIR)/lib/crc-itu-t.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,20,crc-itu-t)
+endef
+
+$(eval $(call KernelPackage,crc-itu-t))
+
+
 define KernelPackage/crypto
   SUBMENU:=$(EMENU)
   TITLE:=CryptoAPI modules
@@ -43,6 +55,19 @@ endef
 $(eval $(call KernelPackage,crypto))
 
 
+define KernelPackage/eeprom-93cx6
+  SUBMENU:=$(EMENU)
+  TITLE:=EEPROM 93CX6 support
+  DESCRIPTION:=Kernel module for EEPROM 93CX6 support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:=CONFIG_EEPROM_93CX6
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,20,eeprom_93cx6)
+endef
+
+$(eval $(call KernelPackage,eeprom-93cx6))
+
+
 define KernelPackage/lp
   SUBMENU:=$(EMENU)
   TITLE:=Parallel port and line printer support
index a4da4ee5b17364b24a724751fe114a263d70152a..22c4f1264882fcc1a231e81488422f0ec547e01f 100644 (file)
@@ -290,7 +290,7 @@ CONFIG_E100=m
 # CONFIG_E1000 is not set
 # CONFIG_ECONET is not set
 # CONFIG_EEPRO100 is not set
-CONFIG_EEPROM_93CX6=y
+CONFIG_EEPROM_93CX6=m
 # CONFIG_EFI_PARTITION is not set
 # CONFIG_EFS_FS is not set
 # CONFIG_ELF_CORE is not set