kexec-tools: Make link /sbin/kexec for compatability with other distros
authorgeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Aug 2009 20:12:41 +0000 (20:12 +0000)
committergeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Aug 2009 20:12:41 +0000 (20:12 +0000)
Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17375 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kexec-tools/Makefile

index 7ee1c2cd5b2c11ba7e0929b8945c5e8bda644f4b..c7e52903897f0ceed305fdd2599cf1ce5e04d022 100644 (file)
@@ -71,6 +71,9 @@ define Package/kexec-tools/install
                $(PKG_INSTALL_DIR)/usr/sbin/kexec \
                $(1)/usr/sbin
 
+# make a link for compatability with other distros
+       $(INSTALL_DIR) $(1)/sbin
+       ln -s /usr/sbin/kexec $(1)/sbin/kexec
 endef
 
 $(eval $(call BuildPackage,kexec-tools))