[backfire] cleanup: remove refs to unsupported "coldfire" target
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Nov 2011 21:44:39 +0000 (21:44 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Nov 2011 21:44:39 +0000 (21:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29309 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 3b4830dcf11f27a26a583cd6eec75242b66c9491..b3d6605ff122c4d4871e67db3d0bdd68b33392be 100644 (file)
@@ -78,7 +78,7 @@ endef
 define Package/libgcc
 $(call Package/gcc/Default)
   TITLE:=GCC support library
-  DEPENDS+=@!(TARGET_avr32||TARGET_coldfire)
+  DEPENDS+=@!(TARGET_avr32)
 endef
 
 define Package/libgcc/config
@@ -161,7 +161,7 @@ define Package/libc/Default
   SECTION:=libs
   CATEGORY:=Base system
   VERSION:=$(LIBC_VERSION)-$(PKG_RELEASE)
-ifneq ($(TARGET_avr32)$(TARGET_coldfire),)
+ifneq ($(TARGET_avr32),)
   DEPENDS:=+libgcc
 endif
   URL:=$(LIBC_URL)
index 0424475432a8f0541b83d41b2633b7f9615417b8..26ae069d4cdd56244e32efc206269781f6d17d5e 100644 (file)
@@ -5,7 +5,6 @@ choice
        default GCC_VERSION_3_4_6 if LINUX_2_4
        default GCC_VERSION_4_2_4 if avr32
        default GCC_VERSION_4_3_3 if powerpc64
-       default GCC_VERSION_4_3_3 if TARGET_coldfire
        default GCC_VERSION_4_4_1 if ubicom32
        default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon)
        default GCC_VERSION_4_3_3_CS if (arm || armeb)
index 9334065ba3e6e9ddbe17688c73467ecc19fd410d..8cd8df401905d4b9754bd0cc8adfa97c749b9bd2 100644 (file)
@@ -66,7 +66,6 @@ if !LINUX_2_4
 
        config GCC_VERSION_4_3_3
                default y if powerpc64
-               default y if TARGET_coldfire
 
        config GCC_VERSION_4_3_3_CS
                default y if (mips || mipsel) && !(TARGET_octeon)