[backfire] merge r21261 & r21262
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 May 2010 11:22:44 +0000 (11:22 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 May 2010 11:22:44 +0000 (11:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@21376 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk
target/linux/generic-2.4/config-default

index 52fbc525ed8ddb0c6b14746db27ce99ac826788d..88b57c56515fbcbce7825766c6b2c2a64c977e3e 100644 (file)
@@ -666,8 +666,16 @@ $(eval $(call KernelPackage,sc520-wdt))
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
-  DEPENDS:=@LINUX_2_6 @!TARGET_x86
+  DEPENDS:=@!TARGET_x86
   KCONFIG:=CONFIG_INPUT
   KCONFIG:=CONFIG_INPUT
+endef
+
+define KernelPackage/input-core/2.4
+  FILES:=$(LINUX_DIR)/drivers/input/input.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,19,input)
+endef
+
+define KernelPackage/input-core/2.6
   FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,19,input-core)
 endef
   FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,19,input-core)
 endef
index 8490f36b39669bc9c9c7e30163afae12922d3023..7871a278852aaa7bb9ec379376d9fa1c7e8c7aa1 100644 (file)
@@ -176,12 +176,17 @@ CONFIG_HOTPLUG=y
 CONFIG_IMQ=m
 # CONFIG_INET_ECN is not set
 CONFIG_INET=y
 CONFIG_IMQ=m
 # CONFIG_INET_ECN is not set
 CONFIG_INET=y
+# CONFIG_INPUT is not set
+# CONFIG_INPUT_DB9 is not set
 # CONFIG_INPUT_EVDEV is not set
 # CONFIG_INPUT_EVDEV is not set
+# CONFIG_INPUT_GAMECON is not set
 # CONFIG_INPUT_GAMEPORT is not set
 # CONFIG_INPUT_GAMEPORT is not set
-# CONFIG_INPUT is not set
+# CONFIG_INPUT_IFORCE_USB is not set
 # CONFIG_INPUT_JOYDEV is not set
 # CONFIG_INPUT_KEYBDEV is not set
 # CONFIG_INPUT_MOUSEDEV is not set
 # CONFIG_INPUT_JOYDEV is not set
 # CONFIG_INPUT_KEYBDEV is not set
 # CONFIG_INPUT_MOUSEDEV is not set
+# CONFIG_INPUT_SERIO is not set
+# CONFIG_INPUT_TURBOGRAFX is not set
 # CONFIG_INPUT_UINPUT is not set
 # CONFIG_INTERMEZZO_FS is not set
 CONFIG_IP6_NF_FILTER=m
 # CONFIG_INPUT_UINPUT is not set
 # CONFIG_INTERMEZZO_FS is not set
 CONFIG_IP6_NF_FILTER=m