minor cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Apr 2007 12:40:20 +0000 (12:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Apr 2007 12:40:20 +0000 (12:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6999 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/Makefile

index e58b310259cbc8daf1f41a9ee27086ce4a232745..8f98be384cfbd1bd6f1ab62be55ed88a7e2f4075 100644 (file)
@@ -49,13 +49,7 @@ define Package/kernel/install
   # nothing to do
 endef
 
   # nothing to do
 endef
 
-# this is more robust than ifdef around eval/call
-ifneq ($(DUMP),1)
-  define BuildKernel
-    $(call BuildPackage,kernel)
-  endef
-endif
-$(eval $(call BuildKernel))
+$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
 include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk
 
 include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk