Added PS3 sound driver
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2009 11:49:22 +0000 (11:49 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2009 11:49:22 +0000 (11:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14422 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 1aa0bf317ac923e4838889c7ac456d86234d4e89..1b9b81a72a17d1cf43bb8d338651c316881e67db 100644 (file)
@@ -91,6 +91,22 @@ endef
 
 $(eval $(call KernelPackage,sound-i8x0))
 
+define KernelPackage/sound-ps3
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=PS3 Audio
+  DEPENDS:=kmod-sound-core
+  KCONFIG:=CONFIG_SND_PS3 \
+               CONFIG_SND_PPC
+  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
+endef
+
+define KernelPackage/sound-ps3/description
+ support for the integrated PS3 audio device
+endef
+
+$(eval $(call KernelPackage,sound-ps3))
+
 define KernelPackage/sound-cs5535audio
   SUBMENU:=$(SOUND_MENU)
   TITLE:=CS5535 PCI Controller