add chillispot
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Apr 2005 00:34:13 +0000 (00:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Apr 2005 00:34:13 +0000 (00:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@501 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/chillispot/Config.in [new file with mode: 0644]
package/chillispot/Makefile [new file with mode: 0644]
package/chillispot/chillispot.control [new file with mode: 0644]
package/chillispot/ipkg/CONTROL/conffiles [new file with mode: 0644]
package/chillispot/ipkg/etc/init.d/S60chilli [new file with mode: 0755]

index 24b3d0da0a40762cff459c9c5c8c4581571d1f19..dca12b8ef3cc02ecc29c2b8231d9c5128eaddaba 100644 (file)
@@ -35,6 +35,7 @@ source "package/portmap/Config.in"
 source "package/nfs-server/Config.in"
 source "package/ser/Config.in"
 source "package/wol/Config.in"
+source "package/chillispot/Config.in"
 
 comment "Libraries"
 source "package/zlib/Config.in"
index 93bc833a507860d1f42491f3f28c717d3330b20c..c42e582098e33993624de65d97eb1ad6fd8d3e05 100644 (file)
@@ -5,6 +5,7 @@ package-y:=openwrt
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
 package-$(BR2_PACKAGE_BRIDGE) += bridge
 package-$(BR2_PACKAGE_BUSYBOX) += busybox
+package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
 package-$(BR2_PACKAGE_CUPS) += cups
 package-$(BR2_PACKAGE_DROPBEAR) += dropbear
diff --git a/package/chillispot/Config.in b/package/chillispot/Config.in
new file mode 100644 (file)
index 0000000..217ece8
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CHILLISPOT
+       tristate "chillispot"
+       default m
+       help
+         ChilliSpot is an open source captive portal or wireless LAN
+         access point controller. It is used for authenticating users
+         of a wireless LAN. It supports web based login which is today's
+         standard for public HotSpots and it supports Wireless Protected
+         Access (WPA) which is the standard of the future. Authentication,
+         authorization and accounting (AAA) is handled by your favorite radius server.
diff --git a/package/chillispot/Makefile b/package/chillispot/Makefile
new file mode 100644 (file)
index 0000000..71736ae
--- /dev/null
@@ -0,0 +1,76 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=chillispot
+PKG_VERSION:=1.0RC2
+PKG_RELEASE:=1
+PKG_MD5SUM:=1b924c0bd592253b1d13af4885ea041a
+
+PKG_SOURCE_URL:=http://www.chillispot.org/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_memcmp_working=yes \
+               ac_cv_func_setvbuf_reversed=no \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib/locate \
+                       --localstatedir=/var/lib \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_NLS) \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/src/chilli: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/src/chilli
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp $(PKG_BUILD_DIR)/src/chilli $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PKG_IPK_DIR)/etc
+       cp $(PKG_BUILD_DIR)/doc/chilli.conf $(PKG_IPK_DIR)/etc
+       cp -a ./ipkg/* $(PKG_IPK_DIR)/
+       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/openvpn.list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/openvpn.list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/package/chillispot/chillispot.control b/package/chillispot/chillispot.control
new file mode 100644 (file)
index 0000000..624dcc5
--- /dev/null
@@ -0,0 +1,7 @@
+Package: chillispot
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot-internal
+Description: ChilliSpot is a Wireless LAN Access Point Controller.
+Depends: kmod-tun
diff --git a/package/chillispot/ipkg/CONTROL/conffiles b/package/chillispot/ipkg/CONTROL/conffiles
new file mode 100644 (file)
index 0000000..0848516
--- /dev/null
@@ -0,0 +1 @@
+/etc/chilli.conf
diff --git a/package/chillispot/ipkg/etc/init.d/S60chilli b/package/chillispot/ipkg/etc/init.d/S60chilli
new file mode 100755 (executable)
index 0000000..0fded5b
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+case $1 in
+ start)
+  /sbin/insmod tun >/dev/null 2>&1
+  [ -d /var/run ] || mkdir -p /var/run
+  /usr/sbin/chilli
+  ;;
+ stop)
+  [ -f /var/run/chilli.pid ] && kill $(cat /var/run/chilli.pid) >/dev/null 2>&1
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?