[backfire] merge r22667
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Aug 2010 09:57:46 +0000 (09:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Aug 2010 09:57:46 +0000 (09:57 +0000)
package/grub: add a prereq check for 32 bits host development files when building on x86_64 (closes: #7753)

git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@22670 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/grub/Makefile

index 5fd2a230883e292b437bf640801ac15844f2b4c7..426b9c367307fc5ede8d1dad88f80bb420ea5e1e 100644 (file)
@@ -88,5 +88,16 @@ define Package/grub/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
+ifeq ($(HOST_ARCH),x86_64)
+  define Require/working-gcc-m32
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc
+  endef
+endif
+
+$(eval $(call Require,working-gcc-m32, \
+       Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+))
+
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,grub))