install missing ebtables files
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jun 2006 02:05:53 +0000 (02:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jun 2006 02:05:53 +0000 (02:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3923 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ebtables/Makefile

index f6f01fac63c83ebd82c41992c9f7d8b2f04458d5..f4359a6675d56e8f9c7482104fa5003d7f5cca6d 100644 (file)
@@ -25,8 +25,13 @@ endef
 define Package/ebtables/install
        install -d -m0755 $(1)/etc
        install -m0644 $(PKG_BUILD_DIR)/ethertypes $(1)/etc/
+       install -d -m0755 $(1)/usr/lib/ebtables
+       install -m0755 $(PKG_BUILD_DIR)/lib*.so $(1)/usr/lib/
+       install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(1)/usr/lib/ebtables/
        install -d -m0755 $(1)/usr/sbin
        install -m0755 $(PKG_BUILD_DIR)/ebtables $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(1)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ebtables))