ppc40x: increase kernel partition size on OpenRB/Magicbox (backport of r20820)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Apr 2010 12:58:38 +0000 (12:58 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Apr 2010 12:58:38 +0000 (12:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@20824 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ppc40x/image/Makefile
target/linux/ppc40x/patches/004-magicbox.patch
target/linux/ppc40x/patches/005-openrb.patch

index 4544aff4ff9db6274f088f9b5b958bd7f357ce3f..c0ecd7f7d9019d0a8ef12ec4645c4e33d12d4528 100644 (file)
@@ -36,11 +36,11 @@ endef
 
 define Image/Build/jffs2-64k
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1152k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-jffs2.img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1152k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-jffs2.img
 endef
@@ -53,11 +53,11 @@ define Image/Build/squashfs
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1152k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1152k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-$(1).img
 endef
index 95736a1e0c8764500e823407e1e8e0bc8a91270c..ff18b49fa0b382542b8ba8c774fcb84c012f413b 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x120000>;
++                                      reg = <0x0 0x140000>;
 +                              };
 +                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x120000 0x2a0000>;
++                                      reg = <0x140000 0x680000>;
 +                              };
-+                              partition@3c0000 {
++                              partition@7c0000 {
 +                                      label = "u-boot";
-+                                      reg = <0x3c0000 0x30000>;
++                                      reg = <0x7c0000 0x30000>;
 +                                      read-only;
 +                              };
 +                      };
index b6dff6eba5b549ae5b0af5afeb0bef380c513425..46ea6f6e0655776953643f9bc0c38c2db750dd29 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x120000>;
++                                      reg = <0x0 0x140000>;
 +                              };
 +                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x120000 0x6a0000>;
++                                      reg = <0x140000 0x680000>;
 +                              };
 +                              partition@7c0000 {
 +                                      label = "u-boot";