[backfire] merge r23201
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Oct 2010 18:13:29 +0000 (18:13 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Oct 2010 18:13:29 +0000 (18:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23202 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/firewall/Makefile
package/firewall/files/reflection.hotplug

index 0445360a3994c9b7323ea98326a1c06ba3e9cd7a..81aff2240e039e66c379af1728f09c29004bb971 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 include $(INCLUDE_DIR)/package.mk
 
index e5194af7df8b76e4871e6e04d8cad9d2bd9920ca..9eab709fecba4a79a0cf67ffb2e605be7e5acd7c 100644 (file)
@@ -15,6 +15,11 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                iptables -t nat -A postrouting_rule -j nat_reflection_out
        }
 
+       iptables -t filter -F nat_reflection_fwd 2>/dev/null || {
+               iptables -t filter -N nat_reflection_fwd
+               iptables -t filter -A forwarding_rule -j nat_reflection_fwd
+       }
+
        find_networks() {
                find_networks_cb() {
                        local cfg="$1"
@@ -38,6 +43,10 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
        setup_fwd() {
                local cfg="$1"
 
+               local reflection
+               config_get_bool reflection "$cfg" reflection 1
+               [ "$reflection" == 1 ] || return
+
                local src
                config_get src "$cfg" src
 
@@ -56,10 +65,6 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                                local proto
                                config_get proto "$cfg" proto
 
-                               local reflection
-                               config_get_bool reflection "$cfg" reflection 1
-                               [ "$reflection" == 1 ] || return
-
                                local epmin epmax extport
                                config_get extport "$cfg" src_dport
                                [ -n "$extport" ] || return
@@ -98,6 +103,11 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                                                                -s $lanip/$lanmk -d $inthost \
                                                                -p $p --dport $ipmin${ipmax:+:$ipmax} \
                                                                -j SNAT --to-source $lanip
+
+                                                       iptables -t filter -A nat_reflection_fwd \
+                                                               -s $lanip/$lanmk -d $inthost \
+                                                               -p $p --dport $ipmin${ipmax:+:$ipmax} \
+                                                               -j ACCEPT
                                                ;;
                                        esac
                                done
@@ -108,4 +118,3 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
        config_load firewall
        config_foreach setup_fwd redirect
 fi
-