do not use the wrapper scripts for exportable toolchains internally. on some systems...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2009 17:23:31 +0000 (17:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2009 17:23:31 +0000 (17:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18454 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/toolchain/Makefile
target/toolchain/files/wrapper.sh [moved from toolchain/gcc/files/wrapper.sh with 100% similarity]
toolchain/gcc/Makefile

index e9b452ec7f1fe0c086eedc4b3895252fd71ada91..fa9405f6cc2fa9af77883a204f8dd1d499e517d1 100644 (file)
@@ -26,6 +26,8 @@ EXCLUDE_DIRS:=*/ccache \
 
 all: compile
 
+TOOLCHAIN_PREFIX:=$(TOOLCHAIN_BUILD_DIR)/toolchain-$(ARCH)_gcc-$(GCCV)_$(LIBC)-$(LIBCV)
+
 $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
        $(TAR) -cf - -C $(TOPDIR)/staging_dir/  \
@@ -36,6 +38,14 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
        $(CP)  $(TOPDIR)/LICENSE ./files/README.TOOLCHAIN \
                $(TOOLCHAIN_BUILD_DIR)/
 
+       $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+       chmod +x $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+       (cd $(TOOLCHAIN_PREFIX)/usr/bin; \
+               for app in cc gcc g++ c++ cpp ld as ; do \
+                       [ -f $(REAL_GNU_TARGET_NAME)-$${app} ] && mv $(REAL_GNU_TARGET_NAME)-$${app} $(REAL_GNU_TARGET_NAME)-$${app}.bin ; \
+                       ln -sf $(REAL_GNU_TARGET_NAME)-wrapper.sh $(REAL_GNU_TARGET_NAME)-$${app} ; \
+               done; \
+       )
        echo REVISION:="$(REVISION)" > $(TOOLCHAIN_BUILD_DIR)/version.mk
        find $(TOOLCHAIN_BUILD_DIR) -name .git | $(XARGS) rm -rf
        find $(TOOLCHAIN_BUILD_DIR) -name .svn | $(XARGS) rm -rf
index 955248e81df9a76d22466695d2e843323a06cb22..ea103c45392cabd7c2c5e610cea24ae14cedb562 100644 (file)
@@ -246,8 +246,6 @@ define Stage2/Install
        $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
-       $(CP) ./files/wrapper.sh $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
-       chmod +x $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
        (cd $(TOOLCHAIN_DIR)/usr; \
                ln -sf $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
                cd bin; \
@@ -255,10 +253,6 @@ define Stage2/Install
                        ln -sf $$$${app} \
                        $(GNU_TARGET_NAME)$$$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
-               for app in cc gcc g++ c++ cpp ld as ; do \
-                       [ -f $(REAL_GNU_TARGET_NAME)-$$$${app} ] && mv $(REAL_GNU_TARGET_NAME)-$$$${app} $(REAL_GNU_TARGET_NAME)-$$$${app}.bin ; \
-                       ln -sf $(REAL_GNU_TARGET_NAME)-wrapper.sh $(REAL_GNU_TARGET_NAME)-$$$${app} ; \
-               done; \
        );
        $(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
 endef