fix rootfs partition name for x86 images
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Oct 2006 22:49:02 +0000 (22:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Oct 2006 22:49:02 +0000 (22:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5367 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/image/x86/Makefile

index fd424ffd0046d8062a1d951a48c77a0725b4b2d2..9b983ad603a82201d89f964bcd7c3a84ce59af3f 100644 (file)
@@ -7,6 +7,10 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
+")) # fix vim's broken syntax highlighting
+
+
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   define Build/Compile
        $(MAKE) -C grub compile
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   define Build/Compile
        $(MAKE) -C grub compile
@@ -17,15 +21,15 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   endef
 
   define Image/cmdline/jffs2-64k
   endef
 
   define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(CONFIG_X86_GRUB_ROOTPART),65536 root=/dev/mtdblock0 rootfstype=jffs2
+    block2mtd.block2mtd=$(ROOTPART),65536 root=/dev/mtdblock0 rootfstype=jffs2
   endef
 
   define Image/cmdline/jffs2-128k
   endef
 
   define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(CONFIG_X86_GRUB_ROOTPART),131072 root=/dev/mtdblock0 rootfstype=jffs2
+    block2mtd.block2mtd=$(ROOTPART),131072 root=/dev/mtdblock0 rootfstype=jffs2
   endef
 
   define Image/cmdline/ext2
   endef
 
   define Image/cmdline/ext2
-    root=$(CONFIG_X86_GRUB_ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
+    root=$(ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
   endef
 
   define Image/Build/grub
   endef
 
   define Image/Build/grub