[backfire] build modules for llc, stp, bridge and 8021q support
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 17:36:34 +0000 (17:36 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 17:36:34 +0000 (17:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29025 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netsupport.mk

index 462be0028eace560d847affbb8dcd075fea6dfdf..9034a0a9e0729726d41a3ffa7ed1fc7b42d93765 100644 (file)
@@ -80,6 +80,65 @@ endef
 
 $(eval $(call KernelPackage,bonding))
 
+define KernelPackage/bridge
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Ethernet bridging support
+  DEPENDS:=+kmod-stp
+  KCONFIG:=CONFIG_BRIDGE
+  FILES:=$(LINUX_DIR)/net/bridge/bridge.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,11,bridge)
+endef
+
+define KernelPackage/bridge/description
+ Kernel module for Ethernet bridging.
+endef
+
+$(eval $(call KernelPackage,bridge))
+
+define KernelPackage/llc
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=ANSI/IEEE 802.2 LLC support
+  KCONFIG:=CONFIG_LLC
+  FILES:=$(LINUX_DIR)/net/llc/llc.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,09,llc)
+endef
+
+define KernelPackage/llc/description
+ Kernel module for ANSI/IEEE 802.2 LLC support.
+endef
+
+$(eval $(call KernelPackage,llc))
+
+define KernelPackage/stp
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Ethernet Spanning Tree Protocol support
+  DEPENDS:=+kmod-llc
+  KCONFIG:=CONFIG_STP
+  FILES:=$(LINUX_DIR)/net/802/stp.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,10,stp)
+endef
+
+define KernelPackage/stp/description
+ Kernel module for Ethernet Spanning Tree Protocol support.
+endef
+
+$(eval $(call KernelPackage,stp))
+
+define KernelPackage/8021q
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=802.1Q VLAN support
+  KCONFIG:=CONFIG_VLAN_8021Q \
+               CONFIG_VLAN_8021Q_GVRP=n
+  FILES:=$(LINUX_DIR)/net/8021q/8021q.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,12,8021q)
+endef
+
+define KernelPackage/8021q/description
+ Kernel module for 802.1Q VLAN support
+endef
+
+$(eval $(call KernelPackage,8021q))
+
 
 define KernelPackage/capi
   SUBMENU:=$(NETWORK_SUPPORT_MENU)