fix multiple ipkg builds of the same arch but with different targets in the same...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Aug 2009 14:04:40 +0000 (14:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Aug 2009 14:04:40 +0000 (14:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17325 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 5d5c826842b33c721c2d33691fbe63ac25b84759..245e29fa5d1d341006fbe64254ffc2015681309c 100644 (file)
@@ -33,7 +33,7 @@ filter_deps=$(foreach dep,$(call strip_deps,$(1)),$(if $(findstring :,$(dep)),$(
 ifeq ($(DUMP),)
   define BuildTarget/ipkg
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
 ifeq ($(DUMP),)
   define BuildTarget/ipkg
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
-    IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
+    IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
     ifdef Package/$(1)/install
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
     ifdef Package/$(1)/install