[backfire] backport r28364
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Oct 2011 23:12:35 +0000 (23:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 4 Oct 2011 23:12:35 +0000 (23:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@28365 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ppp/Makefile
package/ppp/files/ppp.sh
package/ppp/files/pppoe.sh

index 487763e020517e8c523b1814c716612a7e94f5ee..5b034ab34d6474d03066bef0f9c94efddda5fbc6 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=16
+PKG_RELEASE:=16.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 996d542280cd1d8ea59ac4f55951e8ca97fceaea..7c789fc9837d62b680e0def3ae92f9e69572e233 100644 (file)
@@ -16,6 +16,13 @@ stop_interface_ppp() {
 start_pppd() {
        local cfg="$1"; shift
 
 start_pppd() {
        local cfg="$1"; shift
 
+       # Workaround for PPPoE service and AC name options,
+       # filter out the nic-* argument and append it as last option
+       local nic=""
+       case "$1" in
+               nic-*) nic="$1"; shift ;;
+       esac
+
        local proto
        config_get proto "$cfg" proto
 
        local proto
        config_get proto "$cfg" proto
 
@@ -110,7 +117,8 @@ start_pppd() {
                ${disconnect:+disconnect "$disconnect"} \
                ${ipv6} \
                ${pppd_options} \
                ${disconnect:+disconnect "$disconnect"} \
                ${ipv6} \
                ${pppd_options} \
-               nodetach
+               nodetach \
+               ${nic}
 
        lock -u "/var/lock/ppp-${link}"
 }
 
        lock -u "/var/lock/ppp-${link}"
 }
index bbd36a11abee2f11f48e6dbba7d7e32bef04003f..99409f3f08b74c532cf20210641b5641f4b32dd1 100644 (file)
@@ -13,7 +13,7 @@ setup_interface_pppoe() {
        config_get mtu "$config" mtu
        mtu=${mtu:-1492}
        start_pppd "$config" \
        config_get mtu "$config" mtu
        mtu=${mtu:-1492}
        start_pppd "$config" \
+               "nic-$iface" \
                plugin rp-pppoe.so \
                plugin rp-pppoe.so \
-               mtu $mtu mru $mtu \
-               "nic-$iface"
+               mtu $mtu mru $mtu
 }
 }