fix LINUX_KARCH for x86
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2009 21:35:26 +0000 (21:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2009 21:35:26 +0000 (21:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13986 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index a9a350bb280502117b31081e8d5b53ae01924a0f..28567776adec2182daef034aa927c221f7d1ba52 100644 (file)
@@ -53,7 +53,7 @@ ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
 else
   ifeq (,$(LINUX_KARCH))
   LINUX_KARCH:=um
 else
   ifeq (,$(LINUX_KARCH))
-    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/x86/' \
          -e 's/mipsel/mips/' \
          -e 's/mipseb/mips/' \
          -e 's/sh[234]/sh/' \
          -e 's/mipsel/mips/' \
          -e 's/mipseb/mips/' \
          -e 's/sh[234]/sh/' \