improve support for building on mac os x by improving detection of missing components
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2009 19:00:43 +0000 (19:00 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2009 19:00:43 +0000 (19:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14180 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk
scripts/md5sum [new file with mode: 0755]
tools/Makefile

index d6d2d73a63c39549936e19f5e2e4c2920f2fbd55..f0e1da9810d2f51c934cb63e364195e77ae69f2c 100644 (file)
@@ -37,6 +37,20 @@ $(eval $(call Require,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
+define Require/getopt
+       getopt --help 2>&1 | grep long >/dev/null
+endef
+$(eval $(call Require,getopt, \
+       Please install GNU getopt \
+))
+
+define Require/fileutils
+       gcp --help || cp --help
+endef
+$(eval $(call Require,fileutils, \
+       Please install GNU fileutils \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
diff --git a/scripts/md5sum b/scripts/md5sum
new file mode 100755 (executable)
index 0000000..a5779c4
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+cat "$@" | md5
index e24044d1714cf62a4f66a23cdebeab19885f98e9..f2e4bafbfe98923cb3313b8897949f68b77b35e0 100644 (file)
@@ -27,23 +27,20 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
-       @MD5SUM=`which md5sum 2>/dev/null`; \
-       if [ "$@" != "$$MD5SUM" ]; then \
-               if [ -x "$$MD5SUM" ]; then \
-                       ln -sf "$$MD5SUM" "$@"; \
-               else \
-                       cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
-               fi; \
-       fi
-
-$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
-       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
-               ln -sf "$(FIND)" $@; \
-       fi
-
-
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+       @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+       @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+               echo "Command $(1) not found."; false; \
+       }; ln -s "$$$$FILE" "$$@"
+
+endef
+
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)