add a fix to prevent startup crashes on i386 when built with gcc < 4.3
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Jul 2008 12:36:09 +0000 (12:36 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Jul 2008 12:36:09 +0000 (12:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11969 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch [new file with mode: 0644]

diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644 (file)
index 0000000..48cffff
--- /dev/null
@@ -0,0 +1,13 @@
+Index: linux-2.6.26/arch/um/Makefile-i386
+===================================================================
+--- linux-2.6.26.orig/arch/um/Makefile-i386    2008-07-28 13:43:40.412036547 +0200
++++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+@@ -35,7 +35,7 @@
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0430 ] ; then \
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)