[atheros] Implement a preliminary combined image format.
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Sep 2009 01:09:04 +0000 (01:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Sep 2009 01:09:04 +0000 (01:09 +0000)
 - add sysupgrade support for combined images by providing a platform.sh backend
 - use the mtd fis partition table rewrite facility to resize partitions on demand
 - generate generic combined images for the atheros target

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17668 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/combined-image.sh [new file with mode: 0644]
target/linux/atheros/base-files/lib/upgrade/platform.sh [new file with mode: 0644]
target/linux/atheros/image/Makefile

diff --git a/scripts/combined-image.sh b/scripts/combined-image.sh
new file mode 100644 (file)
index 0000000..eecd3d7
--- /dev/null
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+BLKSZ=65536
+
+[ -f "$1" -a -f "$2" ] || {
+       echo "Usage: $0 <kernel image> <rootfs image> [output file]"
+       exit 1
+}
+
+# Make sure provided images are 64k aligned.
+kern=$(tempfile)
+root=$(tempfile)
+dd if="$1" of="$kern" bs=$BLKSZ conv=sync 2>/dev/null
+dd if="$2" of="$root" bs=$BLKSZ conv=sync 2>/dev/null
+
+# Calculate md5sum over combined kernel and rootfs image.
+md5=$(cat "$kern" "$root" | md5sum -)
+
+# Write image header followed by kernel and rootfs image.
+# The header is padded to 64k, format is:
+#  CI               magic word ("Combined Image")
+#  <kernel length>  length of kernel encoded as zero padded 8 digit hex
+#  <rootfs length>  length of rootfs encoded as zero padded 8 digit hex
+#  <md5sum>         checksum of the combined kernel and rootfs image
+( printf "CI%08x%08x%32s" \
+       $(stat -c "%s" "$kern") $(stat -c "%s" "$root") "${md5%% *}" | \
+       dd bs=$BLKSZ conv=sync;
+  cat "$kern" "$root"
+) > ${3:-openwrt-combined.img} 2>/dev/null
+
+# Clean up.
+rm -f "$kern" "$root"
diff --git a/target/linux/atheros/base-files/lib/upgrade/platform.sh b/target/linux/atheros/base-files/lib/upgrade/platform.sh
new file mode 100644 (file)
index 0000000..d4daaac
--- /dev/null
@@ -0,0 +1,76 @@
+CI_BLKSZ=65536
+CI_LDADR=0x80041000
+
+platform_find_partitions() {
+       local first dev size erasesize name
+       while read dev size erasesize name; do
+               name=${name#'"'}; name=${name%'"'}
+               case "$name" in
+                       vmlinux.bin.l7|kernel|linux|rootfs)
+                               if [ -z "$first" ]; then
+                                       first="$name"
+                               else
+                                       echo "$erasesize:$first:$name"
+                                       break
+                               fi
+                       ;;
+               esac
+       done < /proc/mtd
+}
+
+platform_find_kernelpart() {
+       local part
+       for part in "${1%:*}" "${1#*:}"; do
+               case "$part" in
+                       vmlinux.bin.l7|kernel|linux)
+                               echo "$part"
+                               break
+                       ;;
+               esac
+       done
+}
+
+platform_check_image() {
+       [ "$ARGC" -gt 1 ] && return 1
+
+       case "$(get_magic_word "$1")" in
+               # Combined Image
+               4349)
+                       local md5_img=$(dd if="$1" bs=2 skip=9 count=16 2>/dev/null)
+                       local md5_chk=$(dd if="$1" bs=$CI_BLKSZ skip=1 2>/dev/null | md5sum -); md5_chk="${md5_chk%% *}"
+
+                       if [ -n "$md5_img" -a -n "$md5_chk" ] && [ "$md5_img" = "$md5_chk" ]; then
+                               return 0
+                       else
+                               echo "Invalid image. Contents do not match checksum (image:$md5_img calculated:$md5_chk)"
+                               return 1
+                       fi
+               ;;
+               *)
+                       echo "Invalid image. Use combined .img files on this platform"
+                       return 1
+               ;;
+       esac
+}
+
+platform_do_upgrade() {
+       local partitions=$(platform_find_partitions)
+       local kernelpart=$(platform_find_kernelpart "${partitions#*:}")
+       local erase_size=$((0x${partitions%%:*})); partitions="${partitions#*:}"
+       local kern_length=0x$(dd if="$1" bs=2 skip=1 count=4 2>/dev/null)
+       local kern_blocks=$(($kern_length / $CI_BLKSZ))
+       local root_blocks=$((0x$(dd if="$1" bs=2 skip=5 count=4 2>/dev/null) / $CI_BLKSZ))
+
+       if [ -n "$partitions" ] && [ -n "$kernelpart" ] && \
+          [ ${kern_blocks:-0} -gt 0 ] && \
+          [ ${root_blocks:-0} -gt ${kern_blocks:-0} ] && \
+          [ ${erase_size:-0} -gt 0 ];
+       then
+               local append=""
+               [ -f "$CONF_TAR" -a "$SAVE_CONFIG" -eq 1 ] && append="-j $CONF_TAR"
+
+               ( dd if="$1" bs=$CI_BLKSZ skip=1 count=$kern_blocks 2>/dev/null; \
+                 dd if="$1" bs=$CI_BLKSZ skip=$((1+$kern_blocks)) count=$root_blocks 2>/dev/null ) | \
+                       mtd -r $append -F$kernelpart:$kern_length:$CI_LDADR,rootfs write - $partitions
+       fi
+}
index 40044895b87116c839ea4c722e37494fec7f159f..15cd9958654f55cbb145d874a1fee61607d01b9c 100644 (file)
@@ -51,6 +51,12 @@ define Image/Build
                -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                $(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
 
+  ifeq ($(BOARD),atheros)
+       -sh $(TOPDIR)/scripts/combined-image.sh \
+               "$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" \
+               "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+               "$(BIN_DIR)/openwrt-$(BOARD)-combined.img"
+  endif
 endef
 
 $(eval $(call BuildImage))