[toolchain] gcc: only enable/disable TLS support in final stage (closes: #6788)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Mar 2010 17:10:45 +0000 (17:10 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Mar 2010 17:10:45 +0000 (17:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20018 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile

index 9c820f2feca59a81cfec96957c58a7ce9af7ca39..9536cc245bdac5b6685861a17ac450aeb464b6ca 100644 (file)
@@ -116,11 +116,6 @@ else
                --disable-libssp
 endif
 
-ifeq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE+= \
-               --disable-tls
-endif
-
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
                --enable-biarch \
@@ -159,6 +154,14 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-threads \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifneq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE_STAGE2+= \
+               --enable-tls
+else
+  GCC_CONFIGURE_STAGE2+= \
+               --disable-tls
+endif
+
 ifdef CONFIG_powerpc
   TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
 endif