standardize Makefile, change section from base to utils
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Sep 2006 14:01:47 +0000 (14:01 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Sep 2006 14:01:47 +0000 (14:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4831 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/udev/Makefile

index 942e8cf8f490441e238578adffeae06f72df4815..e942442032f4405ccf545074b4a422679547c1d2 100644 (file)
@@ -28,18 +28,18 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(INCLUDE_DIR)/package.mk
 
 define Package/udev
-SECTION:=base
-DEPENDS:=@LINUX_2_6
-TITLE:=Dynamic device management subsystem
-DESCRIPTION:=udev provides a dynamic device directory containing only the files for \\\
-actually present devices. It creates or removes device node files in \\\
-the /dev directory, or it renames network interfaces. \\\
-URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Dynamic device management subsystem
+  DESCRIPTION:=\
+       udev provides a dynamic device directory containing only the files for \\\
+       actually present devices. It creates or removes device node files in \\\
+       the /dev directory, or it renames network interfaces.
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS="$(TARGET_CROSS)" \
                STRIP="/bin/true" \