[backfire] autotools.mk: the old libtool fixup never fully worked, correct it
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2011 20:57:46 +0000 (20:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2011 20:57:46 +0000 (20:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25653 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index 68b5835e97c0e1c7340cdbe7481ee4bc1472d2d9..306b58802e69bb47a3e1eb726f010745b81cb5bf 100644 (file)
@@ -17,7 +17,7 @@ PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
 
 # replace copies of ltmain.sh with the build system's version
 update_libtool_common = \
 
 # replace copies of ltmain.sh with the build system's version
 update_libtool_common = \
-       $(foreach p,$(LIBTOOL_PATHS), \
+       $(foreach p,$(PKG_LIBTOOL_PATHS), \
                $(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(p)/) \
                $(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(p)/) \
        )
                $(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(p)/) \
                $(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(p)/) \
        )