fix dependency bug in wireless-tools makefile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Oct 2005 10:49:51 +0000 (10:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Oct 2005 10:49:51 +0000 (10:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2223 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/wireless-tools/Makefile

index b9cbbde1bde5a8ee2835155c4d0aa031ed1e4bb7..c4767b2127815b5bff2636cbba073034866232ad 100644 (file)
@@ -41,7 +41,7 @@ $(IPKG_WIRELESS_TOOLS):
        $(RSTRIP) $(IDIR_WIRELESS_TOOLS)
        $(IPKG_BUILD) $(IDIR_WIRELESS_TOOLS) $(PACKAGE_DIR)
 
-install-dev:
+install-dev: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/{lib,include}
        cp -a $(PKG_BUILD_DIR)/libiw.so* $(STAGING_DIR)/usr/lib/
        ln -sf libiw.so.28 $(STAGING_DIR)/usr/lib/libiw.so
@@ -51,5 +51,5 @@ uninstall-dev:
        rm -f $(STAGING_DIR)/usr/lib/libiw.*
        rm -f $(STAGING_DIR)/usr/include/{iwlib,wireless}.h
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev