fix target profiles, (closes: 2440)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Oct 2007 19:22:51 +0000 (19:22 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Oct 2007 19:22:51 +0000 (19:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9113 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index 1f17883ab17d062fc240179fe7fb88eb78db0bab..0217fcff6ff287d6a3a36303ac0a8276e6b806ef 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -75,10 +75,22 @@ define Profile
   endif
 endef
 
-ifeq ($(if $(TARGET_BUILD),$(DUMP)),1)
-  -include $(PLATFORM_DIR)/profiles/*.mk
-  ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
     -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endef
+else
+  define IncludeProfiles
+    -include $(PLATFORM_DIR)/profiles/*.mk
+  endef
+endif
+
+ifeq ($(TARGET_BUILD),1)
+  $(eval $(call IncludeProfiles))
+else
+  ifeq ($(DUMP),)
+    $(eval $(call IncludeProfiles))
   endif
 endif