[backfire] backport r25264
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Feb 2011 17:14:14 +0000 (17:14 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Feb 2011 17:14:14 +0000 (17:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25390 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/cmake/Makefile [new file with mode: 0644]

index 5c33202e2cbf5bc6011904c6542f2d03c4c29887..4f5acbd03ad453e546f36722d90ef89a4e640607 100644 (file)
@@ -15,7 +15,7 @@ tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
-tools-y += firmware-utils patch-cmdline quilt yaffs2 xz
+tools-y += firmware-utils patch-cmdline quilt yaffs2 xz cmake
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
new file mode 100644 (file)
index 0000000..dbc2a7e
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cmake
+PKG_VERSION:=2.8.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
+PKG_MD5SUM:=a76a44b93acf5e3badda9de111385921
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))