[package] nvram: request memory locked pages in mmap() and make it available for...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Feb 2010 01:32:47 +0000 (01:32 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Feb 2010 01:32:47 +0000 (01:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19486 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/nvram/Makefile
package/nvram/src/nvram.c

index c2270714fdd301d1d359d577bdaec9316f30220e..f5eba9e2b6874fc0763779a3f98df847311b228a 100644 (file)
@@ -18,7 +18,7 @@ define Package/nvram
   SECTION:=utils
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
-  DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx
+  DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx||@TARGET_ar71xx
 endef
 
 define Package/nvram/description
index ed3da4312b37ce6f01a7a1b7de73256a6d279d58..7ab8c81ab0c489616af66aaa2ce2a3f0a07fcc7e 100644 (file)
@@ -2,7 +2,7 @@
  * NVRAM variable manipulation (common)
  *
  * Copyright 2004, Broadcom Corporation
- * Copyright 2009, OpenWrt.org
+ * Copyright 2009-2010, OpenWrt.org
  * All Rights Reserved.
  *
  * THIS SOFTWARE IS OFFERED "AS IS", AND BROADCOM GRANTS NO WARRANTIES OF ANY
@@ -357,7 +357,7 @@ nvram_handle_t * nvram_open(const char *file, int rdonly)
        {
                char *mmap_area = (char *) mmap(
                        NULL, nvram_erase_size, PROT_READ | PROT_WRITE,
-                       ( rdonly == NVRAM_RO ) ? MAP_PRIVATE : MAP_SHARED, fd, 0);
+                       (( rdonly == NVRAM_RO ) ? MAP_PRIVATE : MAP_SHARED) | MAP_LOCKED, fd, 0);
 
                if( mmap_area != MAP_FAILED )
                {