autotools.mk: Don't try to fixup .la files in the DevInstall host path, because
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 23:40:53 +0000 (23:40 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 23:40:53 +0000 (23:40 +0000)
those .la files shouldn't go there anyway.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19785 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index f85026a944a496c67c9fa9a1f092d0a126e2c9fe..e1535d0b16b3c61a440c92d8582578f44b02c572 100644 (file)
@@ -38,9 +38,6 @@ define libtool_fixup_libdir
        find $(1) -name '*.la' | $(XARGS) \
                $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
                    -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
-       find $(2) -name '*.la' | $(XARGS) \
-               $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
-                   -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
 endef
 
 define remove_version_check