Hopefully fix the PCI resource conflict and upgrade to .24.2
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Feb 2008 11:05:13 +0000 (11:05 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Feb 2008 11:05:13 +0000 (11:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10515 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/au1000/Makefile
target/linux/au1000/patches/015-pci-resource.patch

index e0d916965c8d6bc62f51f52097a5622d575134dc..4566d6c4cb871d776da730d9688f181746ebc437 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index ddbb7ed8a8676d9c44b3897ecbb4e05d5eae8cdd..a9497c7075f505a26f68c796bb3ebc42fcf0bebb 100644 (file)
@@ -1,14 +1,24 @@
---- linux-2.6.22.1.orig/include/asm-mips/mach-au1x00/au1000.h  2007-07-24 18:44:21.598778839 +0200
-+++ linux-2.6.22.1/include/asm-mips/mach-au1x00/au1000.h       2007-07-24 22:08:49.761901610 +0200
-@@ -1680,9 +1680,9 @@
- #define PCI_LAST_DEVFN  (19<<3)
+diff --git a/arch/mips/au1000/common/pci.c b/arch/mips/au1000/common/pci.c
+index c93d7a6..6c25e6c 100644
+--- a/arch/mips/au1000/common/pci.c
++++ b/arch/mips/au1000/common/pci.c
+@@ -39,15 +39,15 @@
  
- #define IOPORT_RESOURCE_START 0x00001000 /* skip legacy probing */
--#define IOPORT_RESOURCE_END   0xffffffff
-+#define IOPORT_RESOURCE_END   0xfffffffffULL
- #define IOMEM_RESOURCE_START  0x10000000
--#define IOMEM_RESOURCE_END    0xffffffff
-+#define IOMEM_RESOURCE_END    0xfffffffffULL
+ /* TBD */
+ static struct resource pci_io_resource = {
+-      .start  = PCI_IO_START,
+-      .end    = PCI_IO_END,
++      .start  = (resource_size_t)PCI_IO_START,
++      .end    = (resource_size_t)PCI_IO_END,
+       .name   = "PCI IO space",
+       .flags  = IORESOURCE_IO
+ };
  
-   /*
-    * Borrowed from the PPC arch:
+ static struct resource pci_mem_resource = {
+-      .start  = PCI_MEM_START,
+-      .end    = PCI_MEM_END,
++      .start  = (resource_size_t)PCI_MEM_START,
++      .end    = (resource_size_t)PCI_MEM_END,
+       .name   = "PCI memory space",
+       .flags  = IORESOURCE_MEM
+ };