[ar71xx] create firmware image for the TL-WR741ND
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Jul 2009 19:58:39 +0000 (19:58 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Jul 2009 19:58:39 +0000 (19:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16741 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk

index b2f51e96ccb2791599096ed0902e03b392581a84..17d20dfa50765ee8c85eae54bbcb67e603601e1e 100644 (file)
@@ -280,6 +280,10 @@ define Image/Build/Profile/MZKW300NH
        $(call Image/Build/Template/Planex/$(1),mzk-w300nh,board=MZK-W300NH)
 endef
 
+define Image/Build/Profile/TLWR741NDV1
+       $(call Image/Build/Template/TPLINK/$(1),tl-wr741ndv1,board=TL-WR741ND,TL-WR741NDv1)
+endef
+
 define Image/Build/Profile/TLWR841NDV3
        $(call Image/Build/Template/TPLINK/$(1),tl-wr841ndv3,board=TL-WR941ND,TL-WR841NDv3)
 endef
@@ -300,6 +304,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MZKW300NH,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
index ba0cb1249376e76b75cee88ecbbdc5f10d4dc2da..551aec9041415f666fc32366e26de8e8ccde66e5 100644 (file)
@@ -5,6 +5,16 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLWR741NDV1
+       NAME:=TP-LINK TL-WR741ND v1
+endef
+
+define Profile/TLWR741NDV1/Description
+       Package set optimized for the TP-LINK TL-WR741ND v1.
+endef
+
+$(eval $(call Profile,TLWR741NDV1))
+
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
        PACKAGES:=kmod-ath9k hostapd-mini