[toolchain/gcc]: make TLS support configurable
[openwrt-10.03/.git] / toolchain / gcc / Makefile
index fe07e7d5c62bfc1e535ac07e64fd5b28410a6bc9..8b920607e021343cbd93dbbf324353d294a8b635 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -116,6 +116,11 @@ else
                --disable-libssp
 endif
 
+ifeq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE+= \
+               --disable-tls
+endif
+
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
                --enable-biarch \
@@ -152,7 +157,6 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
-               --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
 ifdef CONFIG_powerpc