[toolchain/gcc]: make TLS support configurable
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Feb 2010 11:01:28 +0000 (11:01 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Feb 2010 11:01:28 +0000 (11:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19870 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Config.in
toolchain/gcc/Makefile

index 4aaa88edf5846e3760c3d62f818322082f46cf54..b183e3618a31fa454a3de4cf589e2d048db796b5 100644 (file)
@@ -81,6 +81,14 @@ config SSP_SUPPORT
        help
            Enable Stack-Smashing Protection support
 
+config TLS_SUPPORT
+       bool
+       depends !GCC_VERSION_3_4_6 && UCLIBC_VERSION_NPTL
+       prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
+       default n
+       help
+           Enable Thread-local storage support
+
 config INSTALL_LIBSTDCPP
        bool
        prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
index fe07e7d5c62bfc1e535ac07e64fd5b28410a6bc9..8b920607e021343cbd93dbbf324353d294a8b635 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -116,6 +116,11 @@ else
                --disable-libssp
 endif
 
+ifeq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE+= \
+               --disable-tls
+endif
+
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
                --enable-biarch \
@@ -152,7 +157,6 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
-               --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
 ifdef CONFIG_powerpc