[rdc] also support pcmcia
[openwrt-10.03/.git] / target / linux / rdc / image / Makefile
index 6d3825312ff1d87cc83b52991aa973ad0f0b4804..315d917473cde5d3498e33218b4a7915d25cb0ad 100644 (file)
@@ -39,21 +39,21 @@ define Image/Prepare/wl153/squashfs
        echo -n "0123456789abcdef0123" >> $(KDIR)/root.tmp
        cat $(KDIR)/bzImage $(KDIR)/root.squashfs >> $(KDIR)/root.tmp
        dd if=$(KDIR)/root.tmp of=$(KDIR)/root2.tmp bs=64k conv=sync
-       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=$$$$[0x$$$$(cat $(KDIR)/bzSize) + 0x8014]
+       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=$$$$(perl -we 'print((-s"$(KDIR)/bzImage")+0x8014)')
+       $(RM) $(KDIR)/root.tmp $(KDIR)/root2.tmp
        $(call add_jffs2_mark,$(KDIR)/root.squashfs)
 endef
 
 define Image/Build/wl153
-       ls -l $(KDIR)/bzImage | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/bzSize
+       echo -ne "\0\0" >> $(KDIR)/bzImage
+       dd if=$(KDIR)/bzImage of=$(KDIR)/bzImage.tmp bs=4 conv=sync
+       dd if=$(KDIR)/bzImage.tmp of=$(KDIR)/bzImage bs=1 count=$$$$(perl -we 'print((-s"$(KDIR)/bzImage.tmp")-2)')
+       perl -we 'while(<>){$$$$i.=$$$$_}print pack"v",-(unpack"%v*",$$$$i)' < $(KDIR)/bzImage.tmp >> $(KDIR)/bzImage
+       $(RM) $(KDIR)/bzImage.tmp
        $(call Image/Prepare/wl153/$(1))
-       ls -l $(KDIR)/root.$(1) | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/rdSize
-       echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/bzSize)\x$$$$(cut -c 5,6 < $(KDIR)/bzSize)\x$$$$(cut -c 3,4 < $(KDIR)/bzSize)\x$$$$(cut -c 1,2 < $(KDIR)/bzSize)" > $(KDIR)/bzSize.tmp
-       echo -n 'CSYS' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       cat $(KDIR)/bzSize.tmp >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       $(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
-       if [ `ls -l $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi 
+       perl -we 'print "CSYS",pack("V",-s"$(KDIR)/bzImage"),pack("V",-s"$(KDIR)/root.$(1)"),"WRRM",pack("V",-s"$(KDIR)/bzImage")' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       cat $(KDIR)/bzImage $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       if [ `perl -we 'print -s"$(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img"'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi 
 endef
 
 define Image/Build/dir450
@@ -75,8 +75,17 @@ define Image/Build/g570s
        $(RM) -r $(KDIR)/zyxel.tmp
 endef
 
+define Image/Prepare/amit/squashfs
+       echo -n "0123456789abcdef" > $(KDIR)/root.tmp
+       cat $(KDIR)/root.squashfs >> $(KDIR)/root.tmp
+       dd if=$(KDIR)/root.tmp of=$(KDIR)/root2.tmp bs=64k conv=sync
+       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=16
+       $(RM) $(KDIR)/root.tmp $(KDIR)/root2.tmp
+       $(call add_jffs2_mark,$(KDIR)/root.squashfs)
+endef
+
 define Image/Build/amit
-       $(call Image/Prepare/$(1))
+       $(call Image/Prepare/amit/$(1))
        if [ ! -x $(STAGING_DIR_HOST)/bin/amit_makebin ]; then echo "#ERR Please copy the AMIT \"makebin\" tool from http://mgb111.pradnik.net/ as $(STAGING_DIR_HOST)/bin/amit_makebin to build."; fi
        sh -c "mkdir -p $(KDIR)/amit.tmp/linux_src/arch/i386/boot $(KDIR)/amit.tmp/rom_disk && cd $(KDIR)/amit.tmp && ln -s ../../root.$(1) rom_disk/fs.img && ln -s ../../../../../bzImage linux_src/arch/i386/boot && $(STAGING_DIR_HOST)/bin/amit_makebin && mv upgrade.img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-anas350.bin" || :
        $(RM) -r $(KDIR)/amit.tmp