[rdc] also support pcmcia
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Nov 2009 22:55:44 +0000 (22:55 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Nov 2009 22:55:44 +0000 (22:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18349 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc/Makefile
target/linux/rdc/config-2.6.30
target/linux/rdc/config/profile-wl153
target/linux/rdc/image/Makefile

index 0abff003978635ae89a5ebdaeebaa3d1b027412b..09b81c8ab01ae26b074478f2ee0e6b82ff44983b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci usb
+FEATURES:=squashfs jffs2 pci usb pcmcia
 CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
 
 LINUX_VERSION:=2.6.30.9
index 6dc046afe9a71c711e0bb23331a72f18922c743f..81ec1c57a99774df780e60cbd4736a2bda3fefe3 100644 (file)
@@ -28,6 +28,7 @@ CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
 CONFIG_BASE_SMALL=1
 # CONFIG_BINARY_PRINTF is not set
 CONFIG_BITREVERSE=y
+# CONFIG_BLK_DEV_INITRD is not set
 CONFIG_BLK_DEV_RAM=y
 CONFIG_BLK_DEV_RAM_COUNT=16
 CONFIG_BLK_DEV_RAM_SIZE=4096
@@ -52,7 +53,6 @@ CONFIG_CMDLINE_BOOL=y
 # CONFIG_DCDBAS is not set
 # CONFIG_DEBUG_BUGVERBOSE is not set
 # CONFIG_DEBUG_FS is not set
-CONFIG_DECOMPRESS_GZIP=y
 CONFIG_DECOMPRESS_LZMA=y
 CONFIG_DEFAULT_IO_DELAY_TYPE=0
 # CONFIG_DELL_RBU is not set
@@ -132,7 +132,6 @@ CONFIG_HZ_250=y
 # CONFIG_I8K is not set
 # CONFIG_IB700_WDT is not set
 # CONFIG_IBMASR is not set
-CONFIG_INITRAMFS_SOURCE=""
 # CONFIG_IOMMU_API is not set
 # CONFIG_IOMMU_HELPER is not set
 CONFIG_IO_DELAY_0X80=y
@@ -232,8 +231,6 @@ CONFIG_PHYSICAL_START=0x100000
 CONFIG_PROCESSOR_SELECT=y
 # CONFIG_PROVIDE_OHCI1394_DMA_INIT is not set
 CONFIG_RDC321X_WDT=m
-CONFIG_RD_GZIP=y
-# CONFIG_RD_LZMA is not set
 # CONFIG_RELOCATABLE is not set
 # CONFIG_RTC is not set
 # CONFIG_RWSEM_GENERIC_SPINLOCK is not set
index 3e18b0e67714e44f1a56e3c9896ee0eb4905a2ab..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1 +0,0 @@
-# CONFIG_BLK_DEV_INITRD is not set
index 6d3825312ff1d87cc83b52991aa973ad0f0b4804..315d917473cde5d3498e33218b4a7915d25cb0ad 100644 (file)
@@ -39,21 +39,21 @@ define Image/Prepare/wl153/squashfs
        echo -n "0123456789abcdef0123" >> $(KDIR)/root.tmp
        cat $(KDIR)/bzImage $(KDIR)/root.squashfs >> $(KDIR)/root.tmp
        dd if=$(KDIR)/root.tmp of=$(KDIR)/root2.tmp bs=64k conv=sync
-       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=$$$$[0x$$$$(cat $(KDIR)/bzSize) + 0x8014]
+       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=$$$$(perl -we 'print((-s"$(KDIR)/bzImage")+0x8014)')
+       $(RM) $(KDIR)/root.tmp $(KDIR)/root2.tmp
        $(call add_jffs2_mark,$(KDIR)/root.squashfs)
 endef
 
 define Image/Build/wl153
-       ls -l $(KDIR)/bzImage | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/bzSize
+       echo -ne "\0\0" >> $(KDIR)/bzImage
+       dd if=$(KDIR)/bzImage of=$(KDIR)/bzImage.tmp bs=4 conv=sync
+       dd if=$(KDIR)/bzImage.tmp of=$(KDIR)/bzImage bs=1 count=$$$$(perl -we 'print((-s"$(KDIR)/bzImage.tmp")-2)')
+       perl -we 'while(<>){$$$$i.=$$$$_}print pack"v",-(unpack"%v*",$$$$i)' < $(KDIR)/bzImage.tmp >> $(KDIR)/bzImage
+       $(RM) $(KDIR)/bzImage.tmp
        $(call Image/Prepare/wl153/$(1))
-       ls -l $(KDIR)/root.$(1) | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/rdSize
-       echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/bzSize)\x$$$$(cut -c 5,6 < $(KDIR)/bzSize)\x$$$$(cut -c 3,4 < $(KDIR)/bzSize)\x$$$$(cut -c 1,2 < $(KDIR)/bzSize)" > $(KDIR)/bzSize.tmp
-       echo -n 'CSYS' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       cat $(KDIR)/bzSize.tmp >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
-       $(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
-       if [ `ls -l $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi 
+       perl -we 'print "CSYS",pack("V",-s"$(KDIR)/bzImage"),pack("V",-s"$(KDIR)/root.$(1)"),"WRRM",pack("V",-s"$(KDIR)/bzImage")' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       cat $(KDIR)/bzImage $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       if [ `perl -we 'print -s"$(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img"'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi 
 endef
 
 define Image/Build/dir450
@@ -75,8 +75,17 @@ define Image/Build/g570s
        $(RM) -r $(KDIR)/zyxel.tmp
 endef
 
+define Image/Prepare/amit/squashfs
+       echo -n "0123456789abcdef" > $(KDIR)/root.tmp
+       cat $(KDIR)/root.squashfs >> $(KDIR)/root.tmp
+       dd if=$(KDIR)/root.tmp of=$(KDIR)/root2.tmp bs=64k conv=sync
+       dd if=$(KDIR)/root2.tmp of=$(KDIR)/root.squashfs bs=1 skip=16
+       $(RM) $(KDIR)/root.tmp $(KDIR)/root2.tmp
+       $(call add_jffs2_mark,$(KDIR)/root.squashfs)
+endef
+
 define Image/Build/amit
-       $(call Image/Prepare/$(1))
+       $(call Image/Prepare/amit/$(1))
        if [ ! -x $(STAGING_DIR_HOST)/bin/amit_makebin ]; then echo "#ERR Please copy the AMIT \"makebin\" tool from http://mgb111.pradnik.net/ as $(STAGING_DIR_HOST)/bin/amit_makebin to build."; fi
        sh -c "mkdir -p $(KDIR)/amit.tmp/linux_src/arch/i386/boot $(KDIR)/amit.tmp/rom_disk && cd $(KDIR)/amit.tmp && ln -s ../../root.$(1) rom_disk/fs.img && ln -s ../../../../../bzImage linux_src/arch/i386/boot && $(STAGING_DIR_HOST)/bin/amit_makebin && mv upgrade.img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-anas350.bin" || :
        $(RM) -r $(KDIR)/amit.tmp