[brcm63xx] add the CFE offset command line option to the imagetag utility, closes...
[openwrt-10.03/.git] / target / linux / brcm63xx / image / Makefile
index c9a728bbf294a9be956f81ce53a9f9b03f0153cd..b6ef968294d1db99db9bfa1d6295843f7fe3da18 100644 (file)
@@ -37,6 +37,15 @@ define Image/Build/CFE
        $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
 endef
 
+define Image/Build/CFEAGPF
+       # Generate the tagged image
+       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+               -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
+               -v 8 -m IMAGE -k 131072 -n $(4)
+       $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+endef
+
 define Image/Build/RedBoot
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
@@ -96,12 +105,16 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-11,6348)
        # Davolink DV201AMR
        $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
+       # USR 9108
+       $(call Image/Build/CFE,$(1),96348GW-A,6348)
        # DG834GT
        $(call Image/Build/CFE,$(1),96348GW-10,6348)
        # Sagem F@ST2404
        $(call Image/Build/CFE,$(1),F@ST2404,6348)
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
+       # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000)
 endef
 
 $(eval $(call BuildImage))