[brcm63xx] add the CFE offset command line option to the imagetag utility, closes...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Mar 2009 12:29:11 +0000 (12:29 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Mar 2009 12:29:11 +0000 (12:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14896 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index 250cc8236d68300dbb4d331993791f2d14f2473f..b6ef968294d1db99db9bfa1d6295843f7fe3da18 100644 (file)
@@ -42,7 +42,7 @@ define Image/Build/CFEAGPF
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
                -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
                -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
-               -v 8 -m IMAGE -k 131072
+               -v 8 -m IMAGE -k 131072 -n $(4)
        $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
 endef
 
@@ -114,7 +114,7 @@ define Image/Build
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
        # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
-       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358)
+       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000)
 endef
 
 $(eval $(call BuildImage))