Add Wi-Fi profiles (for what it matters with this arch)
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index 70ff003ddd90e4e649a1dbca44bf391b0b04139b..d7b71c803efb1bd24d4e2d2a8011bebf1212111a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs jffs2 broken
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
@@ -21,4 +21,17 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/Atheros
+  NAME:=Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
 $(eval $(call BuildKernel))