Add Wi-Fi profiles (for what it matters with this arch)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Dec 2006 17:56:15 +0000 (17:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Dec 2006 17:56:15 +0000 (17:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5763 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx-2.6/Makefile

index b8da70e13386fedcd21dd5f4bc625daf9852db36..d7b71c803efb1bd24d4e2d2a8011bebf1212111a 100644 (file)
@@ -21,4 +21,17 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/Atheros
+  NAME:=Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
 $(eval $(call BuildKernel))