Add Wi-Fi profiles (for what it matters with this arch)
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index 178a2a79c215fb1ee7e0166c2797a0e4528daa90..d7b71c803efb1bd24d4e2d2a8011bebf1212111a 100644 (file)
@@ -6,17 +6,32 @@
 #
 include $(TOPDIR)/rules.mk
 
+ARCH:=mips
+BOARD:=brcm63xx
+BOARDNAME:=Broadcom BCM963xx
+FEATURES:=squashfs jffs2 broken
+
+define Target/Description
+       Build firmware images for Broadcom based xDSL/routers
+       (e.g. Inventel Livebox, Siemens SE515)
+endef
+
 LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
 
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+define Profile/Atheros
+  NAME:=Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
 
+$(eval $(call BuildKernel))