[atheros] Implement a preliminary combined image format.
[openwrt-10.03/.git] / target / linux / atheros / image / Makefile
index 40044895b87116c839ea4c722e37494fec7f159f..15cd9958654f55cbb145d874a1fee61607d01b9c 100644 (file)
@@ -51,6 +51,12 @@ define Image/Build
                -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                $(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
 
+  ifeq ($(BOARD),atheros)
+       -sh $(TOPDIR)/scripts/combined-image.sh \
+               "$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" \
+               "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+               "$(BIN_DIR)/openwrt-$(BOARD)-combined.img"
+  endif
 endef
 
 $(eval $(call BuildImage))