ar71xx: add profile for the TL-WR841ND v5 board
[openwrt-10.03/.git] / target / linux / ar71xx / profiles / tp-link.mk
index ba0cb1249376e76b75cee88ecbbdc5f10d4dc2da..ab5ed54ca5632ac0dbf83dfaf79a68367e4bd2c0 100644 (file)
@@ -5,6 +5,38 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLWR741NDV1
+       NAME:=TP-LINK TL-WR741ND v1
+endef
+
+define Profile/TLWR741NDV1/Description
+       Package set optimized for the TP-LINK TL-WR741ND v1.
+endef
+
+$(eval $(call Profile,TLWR741NDV1))
+
+define Profile/TLWR841NDV3
+       NAME:=TP-LINK TL-WR841ND v3
+       PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/TLWR841NDV3/Description
+       Package set optimized for the TP-LINK TL-WR841ND v3.
+endef
+
+$(eval $(call Profile,TLWR841NDV3))
+
+define Profile/TLWR841NDV5
+       NAME:=TP-LINK TL-WR841ND v5
+       PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/TLWR841NDV5/Description
+       Package set optimized for the TP-LINK TL-WR841ND v5.
+endef
+
+$(eval $(call Profile,TLWR841NDV5))
+
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
        PACKAGES:=kmod-ath9k hostapd-mini