more fixes for the patching stuff (was testing it on the wrong target)
[openwrt-10.03/.git] / include / quilt.mk
index e77e0db77215f910edfe0c7fb01161e8b705261d..e8c3b90a681d67647fb8794cfed2f02ed3dc4374 100644 (file)
@@ -49,8 +49,9 @@ define Kernel/Patch/Default
                if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
        )
        $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
-               if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+               if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
        )
+       $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)