more fixes for the patching stuff (was testing it on the wrong target)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jun 2007 19:52:54 +0000 (19:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jun 2007 19:52:54 +0000 (19:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7483 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index e77e0db77215f910edfe0c7fb01161e8b705261d..e8c3b90a681d67647fb8794cfed2f02ed3dc4374 100644 (file)
@@ -49,8 +49,9 @@ define Kernel/Patch/Default
                if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
        )
        $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
-               if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+               if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
        )
+       $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)