fix the path to the build dir for host packages
[openwrt-10.03/.git] / include / quilt.mk
index 1bbe9d6ee2142f83dad4498983bdf1e4304a8b2c..6c4839ba4ac324efc5f226e03c9bf548c6fb8572 100644 (file)
@@ -100,8 +100,8 @@ define Quilt/RefreshDir
        mkdir -p $(2)
        -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef