fix the path to the build dir for host packages
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Mar 2009 18:33:40 +0000 (18:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Mar 2009 18:33:40 +0000 (18:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14998 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index 1bbe9d6ee2142f83dad4498983bdf1e4304a8b2c..6c4839ba4ac324efc5f226e03c9bf548c6fb8572 100644 (file)
@@ -100,8 +100,8 @@ define Quilt/RefreshDir
        mkdir -p $(2)
        -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef