add git checkout support
[openwrt-10.03/.git] / include / prereq-build.mk
index 7355b9e31c1e3c8cad24fd54897159717c3d8555..9b77a1baf70b32828aaeb6f0ace064b08fc031fc 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -118,14 +119,19 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
+define Require/git
+       which git-clone
+endef
+
+$(eval $(call Require,git, \
+       Please install git. \
 ))
 
-define Require/find
-       find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
-endef
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
 
-$(eval $(call Require,find, \
-       Please install GNU find 4.2.12 or better. \
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
 ))
+