add git checkout support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2007 03:10:40 +0000 (03:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2007 03:10:40 +0000 (03:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9553 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk
include/prereq-build.mk

index 3866242805c212cd9ba9e346fdc57e149e2f2f68..3c7cb7e77b96d4b4cee813ea8e6ae3ade877ab90 100644 (file)
@@ -46,7 +46,7 @@ endef
 
 define DownloadMethod/svn
        $(call wrap_mirror, \
-               echo "Checking out files from svn repository..."; \
+               echo "Checking out files from the svn repository..."; \
                mkdir -p $(TMP_DIR)/dl && \
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
@@ -59,8 +59,24 @@ define DownloadMethod/svn
        )
 endef
 
+define DownloadMethod/git
+       $(call wrap_mirror, \
+               echo "Checking out files from the git repository..."; \
+               mkdir -p $(TMP_DIR)/dl && \
+               cd $(TMP_DIR)/dl && \
+               rm -rf $(SUBDIR) && \
+               [ \! -d $(SUBDIR) ] && \
+               git-clone $(URL) $(SUBDIR) && \
+               (cd $(SUBDIR) && git-checkout $(VERSION)) && \
+               echo "Packing checkout..." && \
+               rm -rf $(SUBDIR)/.git && \
+               $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+               mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+       )
+endef
+
 Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
 
 define Download/Defaults
   URL:=
index c31020c3211d528acca14d8d4a1a233652dfb1d6..9b77a1baf70b32828aaeb6f0ace064b08fc031fc 100644 (file)
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
+define Require/git
+       which git-clone
+endef
+
+$(eval $(call Require,git, \
+       Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))