add git checkout support
[openwrt-10.03/.git] / include / prereq-build.mk
index c31020c3211d528acca14d8d4a1a233652dfb1d6..9b77a1baf70b32828aaeb6f0ace064b08fc031fc 100644 (file)
@@ -119,6 +119,18 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
+define Require/git
+       which git-clone
+endef
+
+$(eval $(call Require,git, \
+       Please install git. \
+))
+
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))